Problems updating to v4.7.4 or higher

 

A number of Pocket NC V2s produced in the period May-September of 2019 left our facility with an undesired edit to a software configuration file. This does not affect the normal operation of the machine. However, it does mean that our software update process will fail if the update changes the same file.

Affected file: /home/pocketnc/pocketnc/Settings/features/high_speed_spindle/overlay.inc

List of software versions that modify the file:
v4.7.4 - released 14 Oct 2020

At the time of writing, v4.7.4 is the only version released since the machines were produced that edits the affected file. A change going from any version prior to v4.7.4, to version 4.7.4 or later, will fail for affected machines.

Instructions for cleaning your Settings repository

  1. Establish a command line session over SSH.

    • Windows PC: you will need to install an SSH client. We recommend PuTTY.

      • Once PuTTY is installed and launched, we'll just need to input the IP address (192.168.7.2 if connecting over USB) to the Host Name field, everything else can be left default.

    • Macs: this can be done with the default MacOS Terminal

      • Open a Terminal window and enter ssh pocketnc@192.168.7.2

      • You will be prompted for a password, which is pocketnc

  2. In the terminal, enter the following commands:

    1. Change directory to Pocket NC Settings directory

      1 cd /home/pocketnc/pocketnc/Settings
    2. Remove untracked edits from the affected file

      1 git checkout -- features/high_speed_spindle/overlay.inc
    3. Change directory Pocket NC home directory

      1 cd /home/pocketnc/pocketnc
    4. Run update script to ensure everything is in-sync. Replace “v4.7.4” with the desired version.

      1 ./updateScript.sh v4.7.4